
Reference Manual
For Version 1.5.0

jrb
Texte tapé à la machine
http://homepage.mac.com/mdsw/



SOFTWARE LICENSE AGREEMENT

YOU SHOULD CAREFULLY READ THE FOLLOWING TERMS AND CONDITIONS BEFORE EXECUTING 
TweakPDF. EXECUTING TweakPDF INDICATES YOUR ACCEPTANCE OF THESE TERMS AND 
CONDITIONS. IF YOU DO NOT AGREE TO THEM, DELETE TweakPDF FROM YOUR COMPUTER AND 
ALL ASSOCIATED STORAGE MEDIA.

0. Introduction
TweakPDF is distributed as freeware. Since the meaning of this term varies within the software community, this 
license serves to define the terms under which TweakPDF may be used and redistributed.

TweakPDF ©2003-2009 md softworks. All Rights Reserved. This software is distributed free of charge but is not in 
the Public Domain.

1. Definitions and Applicability
This license applies to TweakPDF ("the Software") as distributed by md softworks ("the Author")  to include all 
components of the original distribution package.

The end user ("You") is legally bound by the terms of this license if you use, redistribute or incorporate the Software 
in a larger work. By using the Software, you acknowledge acceptance of the terms of this license and are bound by 
them. If you do not accept the terms of this license, you must discontinue using the Software and delete it from your 
computer and any associated storage media.

2. License
This license permits you to install and use the Software on as many machines as you like without paying the Author 
or any other party a fee for the Software. You may redistribute the Software in its entirety in accordance with the 
provisions set forth in Section 5 of this license. You may use the Software in its entirety as a component of a larger 
work. You may not disassemble, decompile or reverse engineer the Software.

3. Disclaimer of Warranty
THE SOFTWARE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR 
IMPLIED, INCLUDING, BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, 
THAT THE SOFTWARE IS FREE FROM DEFECTS, AND FITNESS FOR A PARTICULAR PURPOSE.

4. Limitation of Liabilities
THE ENTIRE RISK OF USING THE SOFTWARE IS ASSUMED BY THE USER. IN NO EVENT WILL THE 
AUTHOR BE LIABLE FOR ANY INCIDENTAL OR CONSEQUENTIAL LOSSES OR DAMAGES CAUSED 
BY THE USE OR THE INABILITY TO USE THE SOFTWARE.

5. Redistribution
The software may be redistributed in accordance with the following restrictions:

(a) The Software must be distributed in its entirety as originally distributed by the Author. No portion of the software 
may be removed or modified, and no additional items may be added to the software package.

(b) You may redistribute the Software, but you may not charge a fee for it. You may charge a nominal media/
distribution fee. The following is a list of some common redistribution scenarios allowed by this license (this is not 
exhaustive):




 i. The Software may be redistributed by on-line services which charge a service access fee, so long 
as this fee is not specific to accessing and downloading the Software.


 ii. The Software may be redistributed by users groups. If the users group charges a membership 
fee, the fee may not be specific to obtaining the Software.


 iii. The Software may be redistributed as part of a larger collection by a commercial publisher, to 
include as a complement to a print publication, for a nominal media and distribution fee.


 iv. The Software may be used as a component of a "custom software system" provided by a 
systems integrator for which a consulting/development fee is received. HOWEVER, THE 
SYSTEMS INTEGRATOR MUST CLEARLY REPRESENT TO THE END USER THAT THE 
SOFTWARE IS FREELY AVAILABLE TO THEM EXTERNAL TO THEIR CONTRACT WITH 
THE SYSTEMS INTEGRATOR, AND THAT THE SYSTEMS INTEGRATOR HAS NOT 
CHARGED THEM FOR THE SOFTWARE ITSELF. THE SYSTEMS INTEGRATOR MAY 
NOT USE THE SOFTWARE IN THE PROMOTION OF THEIR SERVICES OR PRODUCTS. 
THE SYSTEMS INTEGRATOR MUST INCLUDE THE AUTHOR’S COPYRIGHT NOTICE 
ON THE LARGER WORK.

6. Promotion
The Author’s name and the Software may not be used in any promotion, advertisement or endorsement, either 
directly or indirectly, without expressed prior written consent of the Author.

7. Termination
This license will be terminated automatically if you fail to comply completely with its terms, and fail to correct any 
non-compliance within 30 days of becoming aware or being notified of a breach. Upon termination, you must 
discontinue using the Software and destroy all copies of it in your possession. If you distribute the Software or 
incorporate the Software in a larger work, you must immediately cease distribution or use of the Software in your 
custom software solution. End users who received the Software from you will not be liable for you r breach of the 
license, so long as they are in compliance with the terms of the license, they may continue using the Software.

8. General
This license represents the complete agreement between you and the Author with respect to the Software. This 
agreement is governed by the laws of the United States of America and the State of Maryland. If any provision of 
this license is held to be unenforceable in a legally recognized court of law in the United States of America, that 
provision will be enforced to the maximum extent possible, and all other provisions will remain in full force and 
effect. Previous agreements, if any, are hereby expressly cancelled. This agreement may not be changed or amended 
except in writing by the Author.

The End



Introduction
TweakPDF is a workflow-oriented processor for Portable Document Format (PDF) files.  In this 
version, it features the ability to:


 • set or change the PDF file’s viewer preferences

 • add, set or change Information Dictionary entries

 • set presentation options such as transitions and slide timings

 • set or change page attributes including bounding boxes and rotation

Platforms Supported
TweakPDF is available for the Mac OS and for Windows. For Macintosh, it is provided as a 
universal binary for Mac OS X on both Intel and PowerPC. The Windows version is compatible 
with Windows 2000 and later.

Installation
TweakPDF runs as a stand-alone executable. You can install and run it in any folder on your 
system. Because there is not installer application to configure the system, on Windows systems 
you may need to manually associate the “.pwf” file extension with TweakPDF. 

By default, TweakPDF will write a log file to its application directory and a preferences file to the 
appropriate system-specific directory (“System Folder:Preferences” on the Macintosh and “c:
\Windows” on Windows). The location of the log file can be changed from the File Menu. On 
Windows 2000 or Mac OS X, you should ensure the user running the application has Write 
privileges for the log file directory and any directories in which processed files will be saved.

Application Design
TweakPDF is designed to serve as a stage in an automated workflow that accepts input files, 
processes them according to the workflow’s settings, and then saves the resulting modified PDF 
file. The settings for a workflow can be saved as a file (with a “.pwf” extension on Windows) and 
reopened later. A workflow can be fully automatic, that is, watch for, process and save files 
without interaction. Or it can accept manually selected files or save results to a user-specified 
file. Each workflow is executed as a separate thread, meaning multiple workflows can be run or 
edited simultaneously.

Creating a Workflow
You can start TweakPDF by double-clicking its icon or the icon(s) of any saved workflow files. If 
you start it without specifying an existing workflow file, a new, untitled workflow is 
automatically opened. If you open one or more existing files, they are opened and, if they so 
specify in their workflow configurations, are automatically run (this is a useful capability in an 
unattended server environment). On Windows, TweakPDF can be started from to command line 
and one or more workflow files specified as arguments.



A workflow window is divided into two sections. The top section displays the current status 
(stopped, watching a folder or processing a file) and provides controls to start and stop the 
workflow. There is a small disclosure triangle between the top section and bottom section along 
the left side of the window; clicking this will alternately hide or display the bottom section – this 
setting is remembered from the last time the workflow file was saved and restored when it is 
reopened, as is the position of the workflow window.

The bottom section of the workflow window contains the settings on a series of panels. These 
panels are reached by selecting the appropriate panel name from the drop-down listbox at the 
top of the section. The last panel displayed is remembered when the workflow is saved.

Each panel works the same way. Along the left is a list of properties, and their settings are along 
the right. Some properties can be selected from a popup list, which is indicated by a small arrow 
to the right of the property. Some properties can also be edited or have special selection 
dialogs; this is indicated by three dots at the right of the property’s entry. Clicking the arrow or 
the dots will display the appropriate menu or dialog for selecting and editing. 

In this version, there are five panels: Workflow Settings, Info Dictionary Entries and Viewer 
Preferences, Page Settings and Presentation Settings.

Workflow Settings Panel
This panel is where the basic operation of the workflow is configured. The settings are:

Autostart Workflow: check this box if you want the workflow to start automatically 
when it is opened. This is not available if the workflow only accepts manually selected files 
for input.

Open input file by: the source of input for the workflow. If “Choosing manually” is 
selected, PDF files selected from the Open command in the File menu will be processed. If 
“Watching folder” is selected, then the folder specified will be checked continuously while 
the processor is running looking for PDF files to process. These will be processed one-at-
a-time. If you select this option, you should also ensure “Delete input file” is selected for 
After processing; this will delete the input file to prevent an unending reprocessing of the 
file. If there is an error during processing and the output file cannot be written, the input 
file will not be deleted, but will be renamed with the extension “.err” so that it will not be 
reprocessed. All processing errors are written to the log file which is stored in the same 
folder as the TweakPDF application, or at another location specified by the “Choose 
Logfile...” command in the File menu.

Process subfolders: when checked, all of the folders beneath the selected watch folder 
(or folder selected for manual processing) are also processed. This allows you to maintain 
a directory structure. Use the Mirror subfolder structure in the Output File 
section to replicate the folder hierarchy at the destination, as well.



After processing: This section determines what happens to the input file after it has 
been processed. There are four choices in the dropdown menu: Delete, Rename, Move or 
Do Nothing. 


 
 Delete input file is the default and should be selected for automated 
workflows; if it is not, TweakPDF will automatically change the input file name by adding 
the extension “.done” to prevent the file from being reprocessed. If you are manually 
processing files, you may want to change Delete to Do Nothing to preserve the input file. 


 
 Rename input file changes the input file’s name but leaves it in the same 
folder; the name is specified in the “Move/rename to:” box and may be an expression. 
Warning: on Macintosh, PDF files are identified by their file type, not their extension. 
TweakPDF will reprocess a file if it is simply renamed, even if the extension is not ”.pdf”. 
To prevent this, use the extension “.done”; any file (on Macintosh or Windows) with this 
extension is ignored. 


 
 Move input file moves the file to a different folder, but leaves the name the 
same. One possible use for this is to create a fork in a workflow where the same file can 
be processed in two or more different ways. Select a folder in the “Move/rename to:” 
entry.


 
 Do Nothing with input file leaves the file as it was. As noted above, in an 
automatic workflow, TweakPDF will rename a file with a “.done” extension to prevent a 
processing loop if this option is selected.

Output File determines how the resulting processed file should be handled. If Save 
output to is set to Ask for each file, then the user will be prompted when an input file is 
ready for processing. If it is set to Destination folder, a preset folder to which all output will 
be saved can be selected for the Destination folder entry. If “Mirror subfolder structure” is 
checked, output files will be placed in folders with the same hierarchy beneath the 
selected destination folder as the source files had beneath the source folder. Note that 
this is only available when “Process subfolders” is checked under Input File. The “Save as:” 
field allows you to specify a name for the output file; this will default to the same name as 
the input file if left blank. This field can contain an expression (see Expressions below). The 
output folder should not be the same as the input folder, if one has been selected, to 
prevent the file from overwriting the input and being repeatedly processed (or deleted).

Info Dictionary Entries Panel
The Info Dictionary is a component of a PDF file in which information about the PDF file, or 
metadata, is stored. This is normally automatically created when the PDF file is generated, but 
different generators provide varying levels of support for setting this information. TweakPDF 
allows you to set these values, as well as add new entries. This may be useful for record-keeping 
or providing automated cataloging tools with information.

The panel presents a list of dictionary keys which initially is simply the list of those defined by 
the PDF 1.3 standard. Click to the right of a key to enter its value. A value can be a text string, a 



string with substitution sequences, or an expression (which can include substitution sequences, 
too). Keys with values in the list will be added to the output file or will update an existing value 
for the same key in the input file. Any key which does not have a value assigned will either not 
be added to the output file, or will not be updated in the output file if it exists in the input file. 
Any keys in the input file which do not have a corresponding key in the listbox will be copied 
with their current values through to the output file. Keys are never removed, although you can 
cause one to have a blank value by using the empty string (“$”) substitution sequence below. 

The add a new key, select “Add” from the Edit menu. A dialog will appear allowing you to enter 
the name for the key (it may not contain spaces or certain other characters; the system will 
beep if you type one of these characters). Note that you do not need to enter a leading “/” 
character as would appear internally in the PDF file; this is done automatically. You also need to 
select the type for the value. Generally, a string is sufficient for textual data. Other types are 
only necessary if the file will be processed by a particular application requiring that type.

Any key you have added can be deleted by selecting it and choosing “Delete” from the Edit 
menu. Note that you cannot delete the basic PDF 1.3 keys.

Viewer Preferences Panel
The items on this panel control how the PDF file is displayed when it is first opened with a 
viewer application. Note that these are only suggestions for the viewer application and it does 
not need to implement or adhere to any of them. Some viewer setting are automatically 
overridden by user preferences.

The settings are:

Page mode: one of Normal (just the document), Outlines (bookmarks tab opened), 
Thumbs (thumbnails tab opened) or Fullscreen (presentation mode). If Fullscreen is 
selected, then Non-Full Screen Mode will be enabled, from which you can choose any of 
the remaining options to be used if the user exits presentation mode.

Page Layout: how the pages are displayed in the viewer: Single (one page at a time), 1 
Column (as a continuous column of pages) or 2 Column with either even or odd pages on 
the left-hand side of the display.

Hide toolbar: don’t display the toolbar in the viewer when checked
Hide menubar: don’t display the menubar in the viewer when checked
Hide window user interface: don’t show window controls
Fit page to window size: scale the page to fit in the window, whatever its size
Center window: move the viewer window to the center of the display
Open action: execute an Open Action, as described below

Open Actions are functions which are executed when the document is opened. TweakPDF 
allows you to specify a basic open action to go to a particular page in the document, and scroll 
and zoom it. When you check “Open action:”, you will be able to enter a number in the “Page” 
box; this number is the absolute page number in the document starting from 1, not the page 



number printed on a page or specified as a page label. You then need to select a Destination 
from the popup; the destinations are Fit, FitH, FitV, FitR, FitB, FitBV, FitBH and XYZ. Some of 
these have parameters associated with them that must be supplied in the “Parameters” line; you 
can see the list of parameters by pointing at the field. Enter each parameter in the field 
separated by a single space from the parameter before it. For example, if you choose XYZ, you 
are prompted for “left top zoom”, for which you would enter the left-hand coordinate to 
display, a space, the top coordinate, a space, and the zoom factor.

The Page and Parameters entries can both accept substitution sequences and expressions. 
Substitutions are useful for setting the parameters since you may want to use an open action 
which sets the display to the top of a particular page. The coordinate system in PDF, however, is 
Cartesian, i.e. the lower-left corner is 0,0, making the upper-left corner 0,pageHeight. While you 
could enter a set page height in points (if you know it), this would only work properly for 
documents with that page height rather than being general.

Page Settings Panel
The options on the Page Settings panel allow you to modify the page dimensions and rotation 
for every page in the document. The five bounding boxes, the MediaBox, CropBox, BleedBox, 
TrimBox and ArtBox, define the sizes for each page in a document. If you leave these entries 
blank, the input document settings will be left unchanged. To change one, you must specify a 
string containing four numeric values: the left, bottom, right and top coordinates of the bounding 
box, each separated by a space. These entries will accept substitution sequences and 
expressions, so the can be dynamically managed. If you use an expression, be sure the resulting 
string is in the the proper format. The input values for the current page are available as 
substitution sequence variables.

You can also set the page rotation. You can either choose to leave it as set in the input file 
(Don’t Change), or to a particular 90˚ increment (all clockwise from 0 which is the default).

Presentation Settings
The Presentation Settings panel affects the settings for each page when it is viewed as a 
presentation (i.e. Fullscreen). A presentation consists of transitions (how one slide is changed to 
the next) and a Transition Interval (the time one slide is visible before the presentation advances 
to the next slide). 

If you don’t want to change transition settings, select “Don’t Change” from the Transition type 
dropdown menu. To remove transitions that may be in the file, select “None.” All other settings 
will provide a transition effect. If you select “Random,” TweakPDF will choose a transition while 
processing the file. Note that this selection is then permanent (non-changing) in the file. Enter a 
duration for the transition effect in the “Duration:” box; this is the amount of time (in seconds) 
the effect itself will last and can be an expression. The Dimension, Motion and Direction 
dropdown menus apply to some of the transition types and are enabled as appropriate.

Enter a time (in seconds) for the “Time between slides” box; this is the time a slide is visible 
before the presentation advances and may be an expression.



Bookmarks
This panel allows for the creation of bookmarks and a bookmark tree in the output file. Each 
row in the list becomes one entry in the bookmark outline.  Add entries by clicking the “+” 
button at the bottom of the panel. Provide a title (which can include substitution sequences and 
expressions, discussed below), and the page number; this is the absolute page number in the 
document, and may be an expression. You can also designate the Y value, or vertical position on 
the page that will display when the user clicks the bookmark. This must be a number in the 
range of the pagebox height. Leave this value as “null” to display the top of the page.

To generate a hierarchy, used the “<“ and “>” to outdent or indent selected rows, respectively. 
The marks at the left of the list show the hierarchy. You cannot indent a row more than one 
level beyond its immediate parent. Outdenting a row will automatically outdent all of its 
children.

A row, or group of rows, can be marked as being open by checking the “Open” box. In the 
hierarchy, this will display as a downward-pointing arrow. When displayed in a PDF reader, 
groups that are open will be fully revealed when first viewed.

One or more entries can be deleted by selected them and clicking the “-” button. You can also 
drag one or more rows up or down in the list to reorder them.

Page Labels
In many documents, the page number printed on the page does not correspond to the absolute 
number of the page in the document; additionally, some sections of a document may use 
different number schemes or symbols. Assigning page labels allows the PDF viewer to display the 
page numbers as printed. The Page Labels panel allows you to assign labels to actual page 
numbers.

Labels are organized as ranges. Create a new label range by clicking the “+” button at the 
bottom of the panel. Enter the index, which is the absolute number of the page in the 
document. Note: the index sequence begins with zero (0). Then select the kind of 
numbering sequence to use for the numeric portion of the page label by clicking in the 
“Number Type” column; each click steps through the possible options. If you would like a prefix 
to be prepended to the page label, for example a section number, enter it in the “Prefix” 
column; this value can be a substitution sequence or expression. Finally, indicate the beginning of 
the numeric sequence; by default, this is 1, but you can change it to a higher value.

Labels can be dragged to reorder, and deleted by clicking the “-” button.

Substitution Sequences
There are a number of special substitution sequences you can enter into the edit fields on 
several of the panels that will automatically substitute system-generated text for the sequence 
when the file is processed. Note that although these sequences can be used in any field, they 
may not be applicable or appropriate for certain types of entries. TweakPDF does not perform 
any type-checking on the values entered into these fields; although illegal values are unlikely to 



cause problems with the PDF file itself, they may cause some applications to be unable to read 
the affected object in the PDF file.

All substitution sequences begin with the dollar sign (“$”) and are followed immediately by 
another single character which determines which sequence will be substituted. In the case of 
the “v” substitution, “$v” is immediately followed by the variable name as listed below. These 
sequences are case-sensitive. In the event a single “$” is encountered, no substitution is made, so 
this is effectively the empty string. Substitutions are performed before expressions are 
evaluated, so they can be used in conjunction with expressions. Remember that these are simple 
text substitutions, so if the result is a string in an expression, it needs to be enclosed in 
quotation marks.

 The substitution sequences are:


 $$
 adds a single “$” to the string; use to include a literal “$” in the string

 $F
 the full input file name, including its extension, if any

 $f
 the input file name without its extension

 $A
 the long date formatted as specified on the current system

 $a
 the short date formatted as specified on the current system

 $T
 the long time formatted as specified on the current system

 $t
 the short time formatted as specified on the current system

 $Y
 the year in 4-digit format

 $M
 the month in 2-digit format

 $D
 the day in 2-digit format

 $H
 the hour in 24-hour format

 $m
 the minutes in 2-digit format

 $S
 the seconds in 2-digit format

 $i
 the number of the document in the current run

 $n
 the number of the document since the workflow was opened

 $d
 the date in PDF internal format (without the Universal Time suffix)

The two counters, $i and $n, are useful for sequentially numbering documents. The first, $i, 
keeps a count of the number of documents processed in the current batch. This could be from 
either the last time the start button was clicked, or, if you open a folder of files, for that batch. 
$n keeps a count of all files processed since the workflow was opened. Of you close the 
workflow and reopen it, this gets reset.

The last of these, $d, substitutes the date in a format defined in the PDF Reference Manual (see 
section 3.8.2) with the exception of the optional offset from Universal Time. This date is valid, 
but not universal. To add the Universal Time offset, follow the substitution sequence immediate 
with the appropriate sign (“+” or “-”), the hours offset in 2-digit format, a single-quote (‘), the 
minutes offset, and another single-quote. The current Eastern Standard Time would be 
expressed as this: $d-05’00’ .



Note: in fields that generate file names, the results of substitutions are examined for illegal 
characters (those not allowed in file names by the operating system); these are replaced with a 
hyphen.

There are also several substitution sequences which are only valid while processing a page (i.e. 
for the Page Settings and Presentation Settings panels). These are:

 $h
 the height of the current page (in default units for the PFD file, normally points)

 $w
 the width of the current page in default units

 $vvarname
 substitute a named variable. Valid variables are:


 
 page
 
 current page number

 
 title
 
 document title

 
 subject

 document subject

 
 author

 document author

 
 openname
 name of the file as opened (same as $F)

 
 savename
 name of the output file

 
 mboxt

 page’s mediabox top coordinate

 
 mboxl
 
 page’s mediabox left coordinate

 
 mboxb

 page’s mediabox bottom coordinate

 
 mboxr

 page’s mediabox right coordinate

 
 cboxt
 
 page’s cropbox top coordinate

 
 cboxl
 
 page’s cropbox left coordinate

 
 cboxb
 
 page’s cropbox bottom coordinate

 
 cboxr
 
 page’s cropbox right coordinate

 
 bboxt
 
 page’s bleedbox top coordinate

 
 bboxl
 
 page’s bleedbox left coordinate

 
 bboxb
 
 page’s bleedbox bottom coordinate

 
 bboxr
 
 page’s bleedbox right coordinate

 
 tboxt
 
 page’s trimbox top coordinate

 
 tboxl
 
 page’s trimbox left coordinate

 
 tboxb
 
 page’s trimbox bottom coordinate

 
 tboxr
 
 page’s trimbox right coordinate

 
 aboxt
 
 page’s artbox top coordinate

 
 aboxl
 
 page’s artbox left coordinate

 
 aboxb
 
 page’s artbox bottom coordinate

 
 aboxr
 
 page’s artbox right coordinate

The variables title, author and subject are loaded from the input file at the start of processing 
and may be changed by settings on the Info Dictionary Entries panel. Note that $h and $w are 
always the same as $vmboxt and $vmboxr, respectively.

Expressions
Several of the fields on the panels described above can accept an expression. This is a string that 
is evaluated during the processing of the file and can therefore be dynamically generated. An 
expression is identified by starting the field entry with an equals sign (=) followed by the 



expression’s code. An expression is a fragment written in the RBScript langauge, which is based 
on RealBasic (see the RealBasic Langauge Reference, RBScript object). The expression must 
result in a string (i.e. an assignment to a string variable) and can use any of the legal operators 
and built-in functions of RBScript. The string containing an expression is first processed to 
replace any substitution sequences, so you can use that mechanism as a means for providing 
input to the expression (string values should therefore be quoted). Since the entire result must 
be a string (even for fields which take numeric values, such as the OpenAction page number), be 
sure to convert numeric results to strings with the str() function.

Examples
1. This expression for the output file name on the Workflow Settings panel names the output 
file based on the file’s author name and date:

 =left(“$vauthor-”,19)+”$D$M$Y.pdf”

The built-in left() function is used to ensure the author’s name is not more than 19 characters 
in order to allow 12 characters for the date and extension and not exceed the 31-character 
limit for file names on MacOS 9 and earlier (it is unlikely that the limit for Windows or MacOS 
X would be exceeded, but a similar statement could be used to ensure this).

2. To crop every page by 1/2 inch (36 points) on the left and right, enter the following in the 
CropBox field on the Page Settings tab:


 =str($vmboxl+36)+” $vmboxb ”+str($vmboxr-36)+” $vmboxt”

In this expression, the first part takes the current value for the page’s left margin (mboxl) and 
adds 36 points, moving it to the right. Since the result is a number, it is converted to a string 
with str(). This is the concatenated (with the “+” operator) to the current value for the bottom 
of the page (mboxb). Note that this is part of a string, so is included in quotation marks. Also 
note there is a space before and after $vmboxb to delimit the preceding entry from the next 
entry. The next two entries in the expression take similar forms.

Menu Commands
Most items on TweakPDF’s menus are the standard commands found in all applications. 
However, the following are unique or act differently in TweakPDF:

File > Open...  Opens a workflow, or, if a workflow is currently open, also allows a PDF file to 
be selected to process with the workflow manually.

File > Process File...  Choose a single PDF file to process immediately with the current 
workflow settings.

File > Process Folder...  Select a folder to process immediately with the current workflow. 
If “Process subfolders” is checked in the workflow settings, all folders beneath the selected 
folder will also be processed.



File > Choose Logfile...   Selects the name and location for TweakPDF’s logfile. Errors are 
written to this file during automatic processing. If there is a problem preventing a file from being 
processed, the file will have “.err” appended to its name and an entry will be made in the logfile.

Edit > Add...   Adds an entry to the Info Dictionary list.

Edit > Delete.  Deletes the selected entry in the Info Dictionary list.

Edit > Edit Text...   Selecting this when the cursor is in an edit field causes the text in the 
field to be displayed in a larger editing dialog. Click OK to save any changes or Cancel to revert 
to the original text in the field.

Edit > Preferences...  (Preferences... in the application menu on Mac OS X)  Opens the 
preferences dialog which has two options:


 Show script and expression errors causes a dialog to display if an error is encountered in a 
script or expression. If unchecked, no error is displayed.


 Process jobs in a separate thread allows jobs to be processed in a separate thread of 
execution. If this is not checked, jobs process in the same thread as the application window, 
meaning you will not be able to interact with the window during processing. In this mode, 
processing is slightly faster, so may be appropriate in a server environment where user 
interaction is not necessary.


 Reset all warnings clears any warnings you have disabled (by checking the “Don’t tell me 
about this again” box in the warning dialog).




