Checkbox sur template  (Lu 343 fois) Partager ce sujet Imprimer

1 B


gugus24  16 avril 2021 : 09:16

Bonjour,
Encore moi avec mon formulaire :-)...
J'essai d'ajouter un checkbox sur un template (que j'ai activé via l'oeil dans la gestion des templates), mais la checkbox ne s'attache pas au formulaire. Quelqu'un sait pourquoi cela ne fonctionne pas ?
Merci d'avance

IP archivée


Merlin  16 avril 2021 : 19:42

Bonjour

Il y a des magiciens sur ce forum mais pas de devins.
Il faudrait donc détailler un peu plus et/ou partager ton document, ou un exemple.
 :joker:

IP archivée


gugus24  16 avril 2021 : 21:23

Désolé Merlin,
Je pensais que tu avais encore mon document depuis mon message d’hier.
Je vais le rattacher dès que je peux.
Merci tout de même.

IP archivée


gugus24  17 avril 2021 : 09:20

Bonjour Merlin,
Voici le document. Dans le template "nouvacces",je voudrais ajouter une checkbox qui suit le text BP1 (ecrit en rouge) qui permet d'activer la ligne ainsi de suite.
De plus j'ai acheté les 30 scripts dans le site pour me servir du script "champ au format email", mais lorsque je l'intègre dans un formulaire, si le format n'est pas correct, je suis renvoyé à la premiere page du document. Du coup j'ai finalement retiré le champ email de chaque template et je l'ai intégré sur la premiere page.


Merci beaucoup

IP archivée


Merlin  17 avril 2021 : 19:44

Je pensais que tu avais encore mon document depuis mon message d’hier.
Je ne garde jamais rien par principe.
Par ailleurs je répond à plusieurs questions tous les jours et il m'est impossible de me souvenir quel formulaire était fait par qui.
 :geek:

Dans le template "nouvacces",je voudrais ajouter une checkbox qui suit le text BP1 (ecrit en rouge) qui permet d'activer la ligne ainsi de suite.
Où est la difficulté ?
Il y a le choix entre l'action "Afficher/Masque un champ" ou bien un peu de JavaScript.

De plus j'ai acheté les 30 scripts dans le site pour me servir du script "champ au format email", mais lorsque je l'intègre dans un formulaire, si le format n'est pas correct, je suis renvoyé à la première page du document.
Là on sort du cadre "forum d'entraide" et on passe dans la catégorie SAV, donc on ne va pas régler ça ici.
Il faudrait que tu m'envoies par email ton fichier (celui dans lequel ça renvoie à la 1re page) pour que je puisse l'examiner, bien que je sois convaincu que c'est une coïncidence car ce script ne contient aucun renvoi vers aucune page.

IP archivée


gugus24  17 avril 2021 : 20:12

Je ne garde jamais rien par principe.
Par ailleurs je répond à plusieurs questions tous les jours et il m'est impossible de me souvenir quel formulaire était fait par qui.
 :geek:
Où est la difficulté ?
Il y a le choix entre l'action "Afficher/Masque un champ" ou bien un peu de JavaScript.
Là on sort du cadre "forum d'entraide" et on passe dans la catégorie SAV, donc on ne va pas régler ça ici.
Il faudrait que tu m'envoies par email ton fichier (celui dans lequel ça renvoie à la 1re page) pour que je puisse l'examiner, bien que je sois convaincu que c'est une coïncidence car ce script ne contient aucun renvoi vers aucune page.



Désolé Merlin, je me suis peut-être mal exprimé.
Concernant le checkbox que je veux rajouter, celui-ci ne laisse pas ajouter. Je t'ai attaché le formulaire dans mon post de 09h20. Au fait lorsque tu essaie de rajouter un un checkbox tout simplement depuis l'outil "Prepare Form", le checkbox ne s'attache pas à la page.
Est ce que de ton côté le fait d'ajouter un checkbox sur une page modèle (et non page la page recopiée depuis le modèle) fonctionne ?

IP archivée


Merlin  17 avril 2021 : 20:17

Oui, ça fonctionne.
No problemo.

IP archivée


gugus24  17 avril 2021 : 21:11


C'est tout de même étrange. Je viens de réessayer sur plusieurs ordinateurs et ca ne fonctionne pas.
Donc voici de auelle manière je m'y prends :
  • J'active l'outil organiser les pages
  • Je clique sur "Autres"
  • "Modele de pages"
  • j'affiche "nouvacces" en cliquant sur l'oeil
  • Je me rends sur cette page
  • J'active "Preparer le formulaire"
  • Je clique sur le bouton "Ajouter cases à cocher...."
  • Je place la case sur la page
  • Je clique et là la case disparait.

J'ai ajouté deux captures d'écran : le capture montre le placement de la case  pendant l'ajout avant de cliquer sur la souris pour coller la case. Une fois cliqué, la case disparait.

IP archivée


Merlin  18 avril 2021 : 09:55

- Sur ta capture d'écran on voit la case à cocher (en bleu).  :doute:

- Tu devrais personnaliser ta barre d'outils rapides car ouvrir les panneaux à chaque fois est pénible et peu productif.

- Ci-joint, la coche fonctionne. No problemo.

IP archivée


gugus24  18 avril 2021 : 10:08

Bonjour Merlin,
Oui elle est en bleu. C’est dû au fait que je n’ai pas encore lâché le bouton de souris.  :geek:
Dès que je le lache, le bouton disparaît.
Quant au bouton, tu as bien raison. Je vais faire cela.

IP archivée


gugus24  18 avril 2021 : 10:12

Par contre sur ta capture je vois que tu es sur la page.
Là ça fonctionne chez moi aussi.
 Chez moi le problème survient lorsque j’essaie d’ajouter un checkbox sur une des pages modèle.

IP archivée


bebarth  18 avril 2021 : 11:49

bonjour,
Essaye de supprimer la page modèle (après l'avoir affichée), d'ajouter ta case à cocher et de la recréer...
@+
 :bonjour:

IP archivée


gugus24  18 avril 2021 : 12:21

Bonjour Bebarth,
Effectivement. J'ai renommer le modele (pour ne pas perdre définitivement le modele) et ca fonctionne.  Etrange tout de même.
Un grand merci.

IP archivée


Merlin  18 avril 2021 : 15:11

Citer
Ci-joint, la coche fonctionne. No problemo.
Citer
Par contre sur ta capture je vois que tu es sur la page.
Scuse, j'ai oublié de joindre le document, la coche est bien sur le template.

J'ai eu quelque gros bugs du même acabit, parfois irréversibles, dans des documents utilisant des templates. N'hésites pas à enregistrer une copie régulièrement et avant chaque étape importante.
 :Smiley03:

IP archivée


gugus24  18 avril 2021 : 15:41

Un grand merci une fois de plus pour votre précieuse aide.

IP archivée


gugus24  19 avril 2021 : 13:48

bonjour,
Essaye de supprimer la page modèle (après l'avoir affichée), d'ajouter ta case à cocher et de la recréer...
@+
 :bonjour:
Bonjour Bebarth,
Là je suis au travail et j'essaie de faire la même manip et je n'ai aucun moyen. Est ce que je peux t'envoyer le fichier en message privé pour que tu puisse essayer chez toi ? (pour rappel, je ne parviens pas à attacher un checkbox sur le modele (page 2).


IP archivée


Merlin  19 avril 2021 : 14:10

Est-ce qu'il ne serait pas plus simple de télécharger le fichier qui fonctionne correctement avec la coche et que j'ai posté Hier à 15:11 ?
 :siffle:   :Smiley03:

IP archivée


gugus24  19 avril 2021 : 14:22

Je ne peux pas utiliser le document que je t'avaisi mis en pj, car il y a des données sur ce doc que je ne peux pas mettre en ligne publiquement. Je peux t'envoyer le fichier complet par mp si cela ne te dérange pas?

IP archivée


Merlin  19 avril 2021 : 14:34

Plutôt par email stp : contact [at] abracadabraPDF.net

IP archivée


gugus24  19 avril 2021 : 14:40

Merlin,
Par tout hasard j'a réussi a rajouter un checkbox.
Alors voici ce que j'ai fait. Si je n'affiche que le modele 1 avec l'oeil ca ne fonctionne pas. Par contre si j'ajoute un autre modele à l'affichage avec l'oeil, à ce moment je peux rajouter un checkbox.

IP archivée